Lets Encrypt Vicibox 8.0.1

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

Lets Encrypt Vicibox 8.0.1

Postby Nefariousparity » Sun Dec 08, 2019 7:29 pm

Hello, I had to rebuild two servers today, upon running certbot

Starting new HTTPS connection (1): acme-staging.api.letsencrypt.org
An unexpected error occurred:
The client lacks sufficient authorization :: Account creation on ACMEv1 is disabled. Please upgrade your ACME client to a version that supports ACMEv2 / RFC 8555. See https://community.letsencrypt.org/t/end ... mev1/88430 for details.

https://community.letsencrypt.org/t/end ... mev1/88430

So far all articles to upgrade this on this version of vici are eluding me. Other servers that have already had the certs generated are renewing fine.

#Solution 1
Certbot-Auto
The certbot-auto wrapper script installs Certbot, obtaining some dependencies from your web server OS and putting others in a python virtual environment. You can download and run it as follows:

user@webserver:~$ wget https://dl.eff.org/certbot-auto
user@webserver:~$ sudo mv certbot-auto /usr/local/bin/certbot-auto
user@webserver:~$ sudo chown root /usr/local/bin/certbot-auto
user@webserver:~$ chmod 0755 /usr/local/bin/certbot-auto
user@webserver:~$ /usr/local/bin/certbot-auto --help

---Fails to install completely
Reading installed packages...
'python' is already installed.
No update candidate for 'python-2.7.13-27.15.1.x86_64'. The highest available version is already installed.
'gcc' is already installed.
No update candidate for 'gcc-4.8-11.16.x86_64'. The highest available version is already installed.
'ca-certificates' is already installed.
No update candidate for 'ca-certificates-1_201403302107-12.3.noarch'. The highest available version is already installed.
'libopenssl-devel' is already installed.
No update candidate for 'libopenssl-devel-1.0.2j-38.1.x86_64'. The highest available version is already installed.
'python-devel' is already installed.
No update candidate for 'python-devel-2.7.13-27.15.1.x86_64'. The highest available version is already installed.
'augeas-lenses' is already installed.
No update candidate for 'augeas-lenses-1.2.0-13.3.1.x86_64'. The highest available version is already installed.
'libffi-devel' not found in package names. Trying capabilities.
'libffi-devel-gcc5' providing 'libffi-devel' is already installed.
'python2-setuptools' not found in package names. Trying capabilities.
No provider of 'python2-setuptools' found.
'python2-virtualenv' not found in package names. Trying capabilities.
No provider of 'python2-virtualenv' found.
Resolving package dependencies...
|| DB Schema Version: 1582 || Asterisk 13.29.2-vici || BUILD: 191121-2256 ||VERSION: 2.14-730a||SVN: 3182||6xTelephony||1x Database||1x Slave||1x Web||1x Archive||ViciBox v.9.0.1
Nefariousparity
 
Posts: 274
Joined: Wed Sep 12, 2012 7:01 pm

Re: Lets Encrypt Vicibox 8.0.1

Postby williamconley » Mon Dec 09, 2019 3:49 pm

i note that you are using the sudo command during installation.

log in as root instead of sudo and try again.

of course it could be that these packages are no longer valid, but i always start with the obvious. contrary to popular belief sudo is not the same as root.
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 19124
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: No registered users and 11 guests