Problems with the intial installation Vicibox9

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

Problems with the intial installation Vicibox9

Postby boiken » Fri Nov 22, 2019 7:00 am

Hello
I have been using Vicibox for 5 years and yesterday and today im facing issues.Once i install and reboot the server,i try to reach the webinterface it shows the redirect text and then in gives error 500.On the apache error logs i see this.

[Fri Nov 22 06:54:59.301712 2019] [php7:error] [pid 2815] [client 173.254.241.121:35230] PHP Fatal error: Uncaught Error: Call to undefined function mysqli_connect() in /srv/www/htdocs/vicidial/dbconnect_mysqli.php:78\nStack trace:\n#0 /srv/www/htdocs/vicidial/audio_store.php(40): require()\n#1 {main}\n thrown in /srv/www/htdocs/vicidial/dbconnect_mysqli.php on line 78

Thanks
Website : http://www.bsdev.al
boiken
 
Posts: 128
Joined: Fri Sep 12, 2014 11:56 am
Location: Albania

Re: Problems with the intial installation Vicibox9

Postby boiken » Fri Nov 22, 2019 4:41 pm

I have tried older versions of Vicibox also and im getting the same error and also tried on different server.

Is anybody else having the same problem ?

To me it seems a PHP version problem

Thanks
Website : http://www.bsdev.al
boiken
 
Posts: 128
Joined: Fri Sep 12, 2014 11:56 am
Location: Albania

Re: Problems with the intial installation Vicibox9

Postby Kumba » Sat Nov 23, 2019 2:24 am

Look in the bug fix thread for ViciBox v.9.0. Someone broke the php7-mysql package so you need to remove the repository that installs it. Instructions for how to do that are in there.
Kumba
 
Posts: 814
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: Problems with the intial installation Vicibox9

Postby areon » Sat Nov 23, 2019 4:19 am

Hi,
We have the same problem from 22 October on new installation
areon
 
Posts: 52
Joined: Tue Sep 08, 2015 7:17 am

Re: Problems with the intial installation Vicibox9

Postby Kumba » Sun Nov 24, 2019 1:08 am

areon wrote:Hi,
We have the same problem from 22 October on new installation


Look in the ViciBox v.9.0 bugfix thread. The solution is to remove the bad repository. You can do that with the following:

Code: Select all
zypper rr 1
zypper ref
zypper dup
Kumba
 
Posts: 814
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: Problems with the intial installation Vicibox9

Postby areon » Mon Nov 25, 2019 10:19 am

Thanks! It works!
areon
 
Posts: 52
Joined: Tue Sep 08, 2015 7:17 am


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: No registered users and 8 guests