ViciBox v.8.0 and v.8.1 End of Life and zypper dup

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

ViciBox v.8.0 and v.8.1 End of Life and zypper dup

Postby Kumba » Wed Sep 04, 2019 11:23 pm

The OpenSuSE v.42.3 Database repository has apparently had some early pruning done to it. This results in zypper being unable to follow an update/upgrade path since the repository that MariaDB 10.2 was installed from is no longer there. With normal 'zypper up' this is not a problem as the package is considered orphaned by the package manager and no longer updated. It's frozen basically since it can't figure out how to cleanly move to another version of that package.

However, when you run 'zypper dup', which is the distribution upgrade command, it enables a flag that allows for switching packages to different repositories. This has been used in the past as a method to force driver update patches that otherwise wouldn't have worked properly to get installed. The issue that caused that was cleaned up but doing a 'zypper dup' was somewhat standard for updating the packages.

Now, with the Database repository missing, the 'zypper dup' behavior tries to fill the 'mariadb' package requirement by changing it to the standard OpenSuSE repository. This results in MariaDB 10.0 getting installed and MariaDB 10.2 getting removed. The end result is that the database will refuse to start because a few of the configuration parameters in /etc/my.cnf are invalid in MariaDB 10.0. Now why it couldn't just ignore a configuration parameter it didn't understand instead of throwing an error and dieing I do not know. But that is what happens.

So if you have run 'zypper dup' and the database is now failing to start, you will need to edit /etc/my.cnf and remove the configuration items it is complaining about when you try to start MariaDB. You should also use just 'zypper up' for now since other repositories are also going to keep dieing off.

The good news is ViciBox v.9.0 is on beta 3 and that will likely be it's final release. There's a previous post if you would like to go check it out.
Kumba
 
Posts: 814
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: ViciBox v.8.0 and v.8.1 End of Life and zypper dup

Postby williamconley » Thu Sep 12, 2019 5:48 pm

We've had several clients ask, and while it is *technically* possible to downgrade a server after upgrading (in theory), I've never seen anyone do it.

We do not advise upgrading the OS on a Vicidial server. If it's working, upgrade Vicidial if you want new features but avoid the possibility of breaking the OS. Vicidial can be repaired without a reinstall under almost any circumstances. OpenSuSE ... not so much, unless you are still at least running the same version. Often individual packages can be deleted and reinstalled without much penalty. But the entire OS?

Well, keep good Database Backups on a different server with the standard Vicidial Backup which will automatically write to an external FTP service upon request. Then if you "zypper dup" or "zypper up" and break the whole thing, at least you can restore. And always back up before ANY upgrade. Vicidial or OS.
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 19124
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: No registered users and 5 guests