ViciBox v.9.0 Beta 3

Support forum for the ViciBox ISO Server Install and ISO LiveCD Demo

Moderators: enjay, williamconley, Staydog, mflorell, MJCoate, mcargile, Kumba

ViciBox v.9.0 Beta 3

Postby Kumba » Wed Sep 04, 2019 11:07 pm

Download Beta 3 ISO Here: http://download.vicidial.com/iso/vicibo ... -beta3.iso

The manual has also been updated. The changes are mostly just clarifications of the restrictions ViciBox v.9.0 will have with older installs. The two major issues come from PHP7 compatibility with ViciDial and also from Asterisk 11 no longer compiling on OpenSuSE after 42.3. You'll need to be using SVN version 2960 or higher since you can only run Asterisk 13 on ViciBox v.9.0 and you'll need to be running SVN code 3131 or newer for PHP7 compatibility.

So the short version is this :
- If used only as a database server, can be used in any cluster regardless of SVN revision used
- If used as a Telephony server, must use at least SVN revision 2960
- If used as a Web server, must use at least SVN revision 3131


So how do you know which SVN revision you have? You can check that by doing the following :

1) Log into your ViciDial web interface as an admin user
2) Go to Admin --> System Settings
3) You'll see the "SVN Version" listed two lines down from the top.


Worst case scenario is you will need to do an upgrade of your system to SVN code 3131 or greater in order to use ViciBox v.9.0.
Kumba
 
Posts: 814
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida

Re: ViciBox v.9.0 Beta 3

Postby williamconley » Thu Sep 05, 2019 10:28 am

- If used as a Web server, must use at least SVN revision 2960


Where does the php7 compatibility come into play? Should this say 3131 instead of 2960?
Vicidial Installation and Repair, plus Hosting and Colocation
SugarCRM integration - Customization and Add-ons - We Bring It All Together.
http://www.PoundTeam.com # 352-269-0000 # +44 (203) 769-2294 # +506 4001-8914
williamconley
 
Posts: 19124
Joined: Wed Oct 31, 2007 4:17 pm
Location: Davenport, FL (By Disney!)

Re: ViciBox v.9.0 Beta 3

Postby Kumba » Thu Sep 12, 2019 9:38 am

williamconley wrote:
- If used as a Web server, must use at least SVN revision 2960


Where does the php7 compatibility come into play? Should this say 3131 instead of 2960?


Ooops, typo on my part. I corrected the original post to reflect that.
Kumba
 
Posts: 814
Joined: Tue Oct 16, 2007 11:44 pm
Location: Florida


Return to ViciBox Server Install and Demo

Who is online

Users browsing this forum: No registered users and 5 guests